O900 drops connection

Hi all,

One of our researchers is having trouble with the O900 dropping the connection as soon as opiInitialise is called. Has anyone else seen this?

Hi Andrew,

Yes. I faced this issue. I did the following things. I do not know which one of the following solved the issue. But the issue got fixed after did this.

  1. Reinstall the OPI.
  2. Disconnect cables and reconnect again.
  3. Have a dummy presentation before going into loop.
  4. Now, this is strange. I still sometimes get this error if i source the file from Rstudio. I never faced this issue if i run code via terminal. (have no idea why?)

Few extra tip:

  1. make sure there is network switch between installed between the computer and the OPI.

Hi all,

I just came across this problem when specifying the ‘color’ of a stimulus incorrectly for the O900 in the latest OPI from CRAN. In particular, the color should be
and not

I have added a warning in the code now, which is updated on github, but will take a few days to get to CRAN.

Thanks for Karam at Iowa for helping me find this bug.

Happy New Year!

And here I am again, making similar mistakes…

This time I had stim$x and stim$y as NULL. Perhaps this is why your ‘dummy presentation before the loop’ works. Perhaps the dummy presentation initialises a variable before the loop…

So the moral of the story - a dropped connection means you asked the O900 to present a bad stimulus. Looks like we should improve the error messages…